Ruby Inside

RubyGems 1.5.0 Released: Now Supports Ruby 1.9.2

rubygems.pngRyan Davis has announced the release of RubyGems 1.5.0. It comes just a month after the release of 1.4 which, notoriously, didn't work with Ruby 1.9.2. These problems have now all been ironed out and Ruby 1.8 and 1.9 users alike can safely upgrade (fingers crossed).

RubyGems is the popular (and official - as of Ruby 1.9) Ruby package manager with which most significant Ruby libraries and tools are distributed. The 1.5 release sees it pick up a few bug fixes and some enhancements, including:

To upgrade to RubyGems 1.5.0, run:

gem update --system

Alternatively, you can learn more in the new UPGRADING documentation, or if you don't already have RubyGems for some reason, you can download it from RubyGems.org.

UPDATE: RubyGems 1.5.0 and Bundler are not the best of friends! If you're depending on Bundler tonight, don't install RubyGems 1.5.0 just yet. However, a 1.5 compatible version of Bundler is due within the next 24 hours. A new version of Bundler has been released, supporting RubyGems 1.5.0. Upgrade now :-)

[ad] Spreadable is a powerful 'tell a friend' referral tool you can easily plug into your site. It brings your app powerful viral social tools you and your users can use to spread the word about your work.


Read More